About EasyMorph Tutorials & Examples Web-help

Bypassing https on Server Settings page

Hi,

I notice that since I configured an SSL certificate, that our https://localhost:6330 server settings page is very slow on the EasyMorph server. This is likely caused because the certificate adress has been blocked on the EasyMorph server.

Is there a possibility to configure an HTTP endpoint, so that I can still connect to it via http://localhost:6330 (or on a seperate port) ?

Accessing the Server by HTTP when an SSL certificate has been configured is currently not possible. The slow response of the Server settings page doesn’t look right – we will investigate that.

Meanwhile, try using the domain name or the IP address from the SSL certificate in the page URL, instead of localhost.

Hi @FilipHeyvaert

Would you mind describing in more detail what difficulties you encountered when using https?

Are you using a self-signed certificate or a real one?

What operating system and virtualization technology are you using?

Which browser did you use when opening the page https://localhost: 6330?

When you write

server settings page is very slow on the EasyMorph server

you mean that opening https://localhost: 6330 is slower than accessing https://yourcompany.com:6330, and this only happens on the Windows Server?

Are there any significant differences in the speed of http/https when accessing the server from user workstations?

This is likely caused because the certificate adress has been blocked on the EasyMorph server.

Does this mean that Windows Server cannot verify the certificate chain because access to root CAs are also blocked?

Have you tried installing (importing) your ssl certificate’s certificate chain locally?

In the case of EasyMorph Server, the exchange of data via HTTPS depends entirely on the settings of the Windows operating system. We use and configure the http.sys module to handle HTTP / HTTPS requests.

You might send your replies to our technical support address or post here.

Thanks.

Hi,

Yes, the certificate chain is blocked on the server due to our internal security policy.
and, yes, we did install the certificate chain locally, but this doesn’t help either.

Whatever URL I try out directly on the EasyMorph server always ends up in the same result whereby it takes ages for the initial response of the server settings page. Once passed this initial response, it works well though.

To learn more about EasyMorph visit easymorph.com.