Best Practices for SharePoint Connector

We are looking into pulling files from SharePoint for our data pipeline. Share point requires an AD account to connect. What is the best practice for connecting to SharePoint? If the user who initially creates the connection leaves, and their AD account is removed, will that cause the pipeline to start failing? Is it bad practice to create a service account that is used only for the EasyMorph connector to SharePoint? Is there a better option?

Hi Josh,

Are you going to connect to SharePoint Online or SharePoint on-premises?

SharePoint Online

In this case, user credentials are entered explicitly in the connector settings (see below). If the user leaves and the user’s account is no longer valid, the connector should be configured with other valid credentials.


The “Use Windows credentials” mode is only available for SharePoint on-premises.

Now that they have implemented “double authentification” in my office (with the Authenticator apps on my phone), the SharePoint connector does not seem to work anymore. Any workaround? Anybody else is dealing with this issue?

I tried the SharePoint Connector action and the sharePoint online API ({sharepoint site url}/_api/web/lists/getByTitle(‘{listName}’).

Hi @Nicolas

The only workaround I could think of in such situation is asking your administrator to create a separate account with multi-factor authentication disabled.

You are right, it worked. Thanks !

Tried creating an App Password to connect to Sharepoint Online but still getting the below error:


Is there any other way to connect EM to Sharepoint without creating a Non-MFA Account?

Not in SharePoint Online.

We’re aware about the problem and are working on adding support for an authentication method (OAuth) that is supported by SharePoint Online. It may take a few days. Once it’s available, we will post an update in this thread.

Version v5.3.2 has just been released. It supports MFA accounts in SharePoint Online. Download it from our website. If you have EasyMorph Server, it also has to be updated to v5.3.2.

  1. Choose “Multi-factor authentication”
  2. Press “Authorize”