About EasyMorph Tutorials & Examples Web-help

Application Crash


#1

Hi. I have asked a staff member to review EasyMorph and they have installed 3.5.0.2

They started to create a project by Clicking NEW and dragging an excel file into the workspace. They then clicked SAVE and were presented with the below Crash Dump.

I had a previous version of EasyMorph for evaluation but installed to the same version and was able to successfully complete exactly the same task proving it is an environment issue. We both run Windows 7 with basically the same updates. However, there could be a difference with .NET if that is used.

Any Ideas? Thanks

The following is the error message shown in EasyMorph Version 3.5.0.2.

Problem signature:
Problem Event Name: APPCRASH
Application Name: Morph.exe
Application Version: 1.0.0.0
Application Timestamp: 59009284
Fault Module Name: KERNELBASE.dll
Fault Module Version: 6.1.7601.23796
Fault Module Timestamp: 59029714
Exception Code: c0000005
Exception Offset: 000000000001a06d
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 3081
Additional Information 1: a401
Additional Information 2: a4015640a11252a6595c9c70812625aa
Additional Information 3: e3f7
Additional Information 4: e3f7e94cded7a4d0555437b8c70a9d37


#2

Please send us EasyMorph debug logs so that we can see exactly what happened.
Debug logs can be found in the Users/[User Name]/AppData/Local/EasyMorph/Debug Logs. Archive the folder contents to a zip file, and send it to support@easymorph.com.

Also, please let us know whether you tried to reproduce the problem on your system using the Excel file that was causing problems on the other system, or some other Excel file?


#3

Thanks for your reply.

The log does not seem to contain any error but I have zipped and sent as requested. I can also confirm that I have the exact same version of EasyMorph and the problem does not occur. Based on that it is related to something specific on the other workstation but will need some hints as to what it may be.

Thanks


#4

Hi Bruce,

Please let us know the exact versions of Windows and .Net Framework installed on the computer where the problem occurs?

Also, could you please send us the Excel file that causes the problem, if possible?

If that is not possible, could you please try to reproduce the problem on one more computer using the same version of EasyMorph and Excel file?

Thanks


#5

Thanks. In my opinion the excel file is not the issue as we have changed it numerous times with the same result and it is nothing special. Just a list of names and some columns of alpha, date and numeric values that is hand crafted to test EasyMorph. On the workstation that fails the .NET platform is as follows...

.NET Framework v4.6.01055
.NET Framework 4 Multi-Targeting Pack v4.0.30319
.NET Framework 4.5 Multi-Targeting Pack v4.5.50710
.NET Framework 4.5.1 Multi-Targeting Pack v4.5.50932
.NET Framework 4.5.1 SDK v4.5.51641
.NET Framework 4.5.2 Multi-Targeting Pack v4.5.51209

These are the same on the workstation that works except that the version number for 4.5.2 is v4.51651 AND
the workstation that works has .NET Core 5.0 SDK and 4.6 SDK - probably from different tools being installed such as Visual Studio Community etc.

I guess the question is - What .NET platform does EasyMorph require?


#6

Hi Bruce,

it happens very rarely but sometimes core C++ redistributable packages can be missing. Can you please install this package on the computer where the failure occurs and try it one more time: https://www.microsoft.com/en-us/download/details.aspx?id=53587

If you installed Visual Studio on the other machine then most probably it already has the package installed (it comes with VS installer) and this can explain the difference in behavior.

EasyMorph requires .NET 4.5 or above and I see that it's already installed on the computer in question.


#7

Bruce,

we've also updated the application to v.3.5.0.3 as we've found a minor issue that potentially might introduce an undesired system dll dependency. The updated version is available on our web-site: http://easymorph.com/download.html

With .NET 4.5 and VS2015 C++ Redistributable (mentioned above) installed there are no other pre-requisites for EasyMorph.

If the problem persists, I'd start suspecting system corruption that led to incorrect system dll versioning or referencing in the registry.

Thanks


#8

Hi,

After reinstalling .NET, installing the distribution librraies, running sfc /scannow and installing and Windows updates. The problem continued to persist.

I saw this new post and found that removing Dell Backup and Recovery also resolved this issue