After updating to v5.3, Server Link is not working in EasyMorph Desktop installed in our Server

Hello,

After updating to EasyMorph Desktop + Server 5.3, my copy of EasyMorph Desktop installed in the same server as where EasyMorph Server is installed can’t connect to the Connector Repository via “Server Link”, I get the following information:

image

Why could this be happening? In another EasyMorph Desktop that I have installed outside the Server, the Server Link works properly after the update, but not here.

Thanks,

Roberto

Hi, did you try “localhost” to fix temporarily the issue at least ?

Hello @RJO yes I tried localhost but that doesn’t work. Should the port be “443” with localhost?

Thanks!

Roberto

UPDATE: The issue has been solved by adding a loopback IP in host entry file to resolve the site locally inside the server (so in theory not related to the upgrade of EasyMorph Server).

I don’t know though why I have only experienced this issue after upgrading EasyMorph Server.

Regards

Starting from version 5.3, Desktop detects if the Server uses SSL (HTTPS) and automatically switches to SSL if it does. The port should always be 6330 (unless you configured Server to use another port) regardless of whether you use SSL or not.

Ok thanks. In our case we have configured port 443 to be used with EasyMorph Server, so that’s what we were using in the Server Link, but it started to fail after the upgrade only in the EasyMorph desktop installed in the same computer as EasyMorph Server. As I mentioned, the issue has been solved by adding a loopback IP in host entry file to resolve the site locally inside the server, but I don’t understand why I got this error just after upgrading EasyMorph.

Hi @roberto

We’ve just checked the automatic HTTP->HTTPS upgrade in EasyMorph Desktop 5.3. And everything works as expected.

Seems, that a DNS/routing misconfiguration caused this issue. Could you open https://server in a browser directly from the server? Where server - is the redacted server name from your screenshot.

Hello @ckononenko, it was an internal issue on our side, now it is solved, thanks!

1 Like