About EasyMorph Tutorials & Examples Web-help

42601 error while adding Like condition in query editor

I am getting error 42601: unterminated quoted string near or at “” as soon as I add “LIKE” condition in the query editor.

Any idea what is the issue?

Can you post the SQL query that EasyMorph generates under the hood? You can see it by pressing “View SQL”

Hi @dgudkov
Please see below:

SELECT *
FROM “tx”.“abc”
WHERE “dvutenancy” = ‘IT’
AND “dvuorganisation” LIKE ‘%Business Services & Support%’ ESCAPE ‘’

Hi @vaibhavtandon87,

Can you please tell us which database and which version you are using?

Its amazon redshift data base and I am using Easymorph latest version.

And which SQL dialect is selected in the settings of your Amazon Redshift connector?

sorry, didnt get that? what is that and where can I check?

Please open the Connector manager ("Add/edit connectors button on the Start tab screen or “Connector manager” button on the “Project” tab), choose connector which you are using in the “Import from database” action and check which dialect is selected in the “SQL dialect” setting:

image

Sorry to confuse you and my mistake. The databases are Amazon redshift but I am using the connector as Postgre SQL.

For Amazon Redshift the SQL dialect in EasyMorph should be also Amazon Redshift.

Hi @dgudkov,

the problem is that when I am using the Postgre SQL connector I am not getting option of SQL dialect anywhere?

For Amazon Redshift there is only an ODBC driver provided by Amazon. When you create an ODBC connection in EasyMorph it’s possible to select an SQL dialect as in the @andrew.rybka’s screenshot above.

For the native PostgreSQL connector there is no possibility to choose an SQL dialect because for a PostgreSQL database it’s apparently always the PostgreSQL SQL dialect.

While Amazon Redshift is somewhat similar to PostgreSQL in terms of SQL syntax, they are not identical - there are differences. That’s why when working with Amazon Redshift the Redshift SQL dialect must be used in an ODBC connection.

I have now installed the ODBC driver provided by amazon and following Andrew’s steps and selected Amazon Sql dialect but where to enter details of server, database, port etc? I cant see that in this option.

sorry but really not able to get this through.Your guidance will be helpful.

This has to be configure in the Windows ODBC driver settings. Go to ODBC (64-bit) settings in Windows and configure the Redshift driver (database, port, etc) there. EasyMorph is only using the driver as it’s configured in Windows.

1 Like

Thanks @dgudkov for your guidance and it helped in resolving the issue!

Regards
vaibhav

To learn more about EasyMorph visit easymorph.com.