Tutorials & Examples Web-help Blog

Get input from user (parameter not prompting)


#1

I would like to prompt the user for a simple input (i.e., a date). I created a parameter and parameter-table and then referenced them with a “peek” action (to append the date).

When I read the documentation on parameters, it suggests the user should be prompted for the parameter (All non-calculated parameters are prompted on full project runs …) but that is not happening the way I would expect. What I’d like to see is some form of interaction where the user can enter a new date (without going through the parameter editor).

This is my initial attempt so I may be missing an easier way to get a value from the desktop user. I’d appreciate any help/advice. Thank you


#2

Attempt-2 Tried to use the CalculateNewColumn action to append the date (instead of the parameter-table approach in my earlier post).

As before, the action works correctly … it’s just not prompting the user to enter a new value.


#3

It seems that the corresponding part of the documentation is outdated.

Parameters may be prompted in EasyMorph Server and EasyMorph Launcher when corresponding option is turned on for a task.


#4

Thank you Andrew … the suggestion of going to the Launcher and setting the “prompt” option worked. thx