About EasyMorph Tutorials & Examples Web-help

Expression Editor Never Appears

As of the latest update, when I attempt to add a parameter and click on the Expression editor, the editor itself never appears. The application acts like it popped up somewhere tho. When I click into the EasyMorph interface, the computer will ding like I am attempting to click outside what would be the Expression editor. If I hit the escape key, I am returned back to normal operation.

I have resized EasyMorph and moved it off to the side to make sure it wasn’t appearing behind the program itself. I have tried minimizing everything else and seeing if it appeared on one of my other monitors. I WindowsKey+D to minimize everything and then clicked on EasyMorph again to see if it would then appear and it doesn’t.

EasyMorph version: 4.6.2.1 (9a6684, 'Release')
Path to morph.exe is C:\Users\FAKEUSERNAME\AppData\Local\EasyMorph\
Operating system: Microsoft Windows 10 Enterprise 10.0.18363
.NET Framework 4.6 or later (4.0.30319.42000)
Latest installed .NET Framework: 4.8 or later (release 528040)
Total physical memory: 31.76 GB
Screen resolution: 6912 x 2808

Try deleting the application config file located here:

C:\Users\<your username>\AppData\Local\EasyMorph\EasyMorph.config.xml

EasyMorph will recreate the config file automatically. Although, some application settings will be lost and will need to be re-configured again.

It might be a good idea to create a copy of the file before deletion, just in case.

1 Like

That worked, thanks.

Yes it also happens sometimes to us. In order not to lose everything from the config file, it seems you can only remove these 4 lines (or reajust them), of course editor would have to confirm :slight_smile:

< ExpressionDialogLeft>…</ ExpressionDialogLeft>
< ExpressionDialogTop>…</ ExpressionDialogTop>
< ExpressionDialogWidth>…</ ExpressionDialogWidth>
< ExpressionDialogHeight>…</ ExpressionDialogHeight>

(I put spaces after < because it seems forum takes XML into account which could be a security issue ?)

1 Like

Yes, that would work too and is an even better solution.

I tried deleting the text and it didn’t fix the issue. had to delete the file to get the Expression Editor to pop up.
I have multiple screens if that helps.

I see it’s a common issue. In version 4.7 we will add a button in the Application Preferences dialog to reset window positions.

1 Like

Very very good news because here in Natixis we have the exact same issue with multiple screen of different size.

To learn more about EasyMorph visit easymorph.com.