About EasyMorph Tutorials & Examples Web-help

Error: Can't get DataTypesMap because it was not stored

Hi!
I create the project in the EasyMorph Desktop and when i run project from EasyMorph Desktop all ok but when i run using EasyMorph Command Line Worker - geting error:

C:\Program Files (x86)\EasyMorph Command Line Worker>.\morph-cmd.exe C:\Users\polyakov\Documents\testproj\testproj_main.morph /param:Filename=“SHOPDIC” /param:Customer=“Customer1” /param:Method=“Access” /projectlogpath:C:\Users\polyakov\Documents\testproj
EasyMorph Command Line Worker v4.9.9.0
Running project C:\Users\polyakov\Documents\testproj\testproj_main.morph
Command line: .\morph-cmd.exe C:\Users\polyakov\Documents\testproj\testproj_main.morph /param:Filename=“SHOPDIC” /param:Customer=“Customer1” /param:Method=“Access” /projectlogpath:C:\Users\polyakov\Documents\testproj
Project C:\Users\polyakov\Documents\testproj\testproj_main.morph ran with errors:
Error: Can’t get DataTypesMap because it was not stored
Source: action “Database command”, module “Access_load_files”, table “SHOPDIC (2)”

Error: Iteration of module “Access_load_files” failed on iteration #1.
Source: action “Iterate table”, module “Main”, table “Access_2”

Called module: module “Access_load_files”
Overridden parameters:
{Customer} = Customer1
{FName} = SHOPDIC.qvd

How i can correct - Error: Can’t get DataTypesMap because it was not stored?

It appears to be a bug :frowning:
We are hoping to fix it by the end of this day

1 Like

I hope so too!
Can you reply in this topic when bugs is fixing?

Yes, we’ll post notification here

1 Like

Maybe if i upload to you my project it is help you?

https://drive.google.com/file/d/1E6Q_qi2AsaBJqbJiasiVAbNhFj6j1Us3/view?usp=sharing

The updated version has been uploaded. You can get it here: EasyMorph | All downloads

1 Like

Thanks!
In my project i can pass 3 parameters:
Filename
Customer (Customer1, Customer2,3,4,5)
Method (Access, Excel, DBF)
After the update, they started working when I transfer Method Excel or DBF, but it does not work when I transfer Method Access. In desktop version all work fine.
I get the same error.
https://drive.google.com/file/d/1KJtgVJ9GB0oEg4WSxlY1nssYQNb6rI9Z/view?usp=sharing

Unfortunately I can’t reproduce Access method error, and that’s suspicious because code that loads DataTypesMap doesn’t depend on connector type (access/DBF). Could it be that you updated command line worker between these tests? I would ask you to re-run the access case once more and maybe could you post a console screenshot with an error here

I recorded video

Looks like you have not updated your command line worker. In your video it says 4.9.9, but current version is 5.0.0.1

1 Like

Today i redownloaded new version of CLW and after update all work fine.
Thanks for the help!

You’re welcome :slight_smile:

To learn more about EasyMorph visit easymorph.com.