About EasyMorph Tutorials & Examples Web-help

Character encoding when exporting to database


#1

I have:

  • A MySQL database with default utf8 collation
  • An Excel file with Arabic in it
  • An EasyMorph project that reads the Excel file and then exports it to the MySQL database

When I run the EasyMorph project, in MySQL I see question marks where there should be Arabic. In EasyMorph, I see Arabic. In Excel, I see Arabic.

I can enter Arabic directly into MySQL (using HeidiSQL for example) and it appears fine.

How do I correct this issue?


#2

If it’s helpful, I would be happy to share the example Excel, EasyMorph, and MySQL, but don’t see a way of uploading this into this community.


#3

That will be very helpful, thanks.

You can just drag and drop files to the Reply text area.
Also there should be an upload icon above just before Bulleted List icon.

It’s possible that community will not accept some of the files because of their extensions. In that case
you can add those files to a ZIP archive and upload that file. ZIP files are accepted by the community.


#4

I have attached:

  • Excel file
  • MySQL database dump
  • EasyMorph project

Note that in the data of the MySQL database, the first row in the table is what I get from the EasyMorph transformation, and the second row is when I cut and pasted the Arabic test via HeidISQL.

arabic_test.zip (15.8 KB)


#5

Thank you for attaching the files.

Have you tried to import exported data back to EasyMorph? Does it shows question marks instead of Arabic text too?

Can you please tell me which version of EasyMorph an which type of connector (EasyMorph’s build-in MySQL connector or ODBC) do you use?


#6

Here’s what happens when I import back into EasyMorph — it shows the question marks:

07

I use EasyMorph’s built-in MySQL connector:


#7

Thank you.

Unfortunately I can’t reproduce this problem with build-in MySQL connector and current version of EasyMorph on our test server. Can you please tell me which version of EasyMorph do you use?


#8

I am using EasyMorph 3.6.0.1.


#9

David, I sent you a private message through the community. Please check it out.


#10

Well, it looks like it was an issue with the MySQL server I was using. I moved to another server, and it seems to be working. I have no idea what my original MySQL server issue was.

Thanks a lot for the detailed help.